The incident has been resolved; our systems indicate that our VPN service is fully operational and that all SIMs should now be reachable.
Posted Mar 26, 2026 - 16:30 CET
Monitoring
We have identified the issue and we have implemented a fix. We are observing full recovery across the VPN service and devices should now be reachable.
We are continuing to monitor to ensure full restoration.
If you have any further questions, please contact our Support Team at support@onomondo.com
Posted Mar 26, 2026 - 16:21 CET
Update
We're continuing to investigate and will provide further updates as more information becomes available.
If you have any further questions, please contact our Support Team at support@onomondo.com
Posted Mar 26, 2026 - 15:45 CET
Update
We're continuing to investigate and will provide further updates as more information becomes available.
If you have any further questions, please contact our Support Team at support@onomondo.com
Posted Mar 26, 2026 - 15:15 CET
Investigating
We are investigating an issue with the VPN service causing SIMs to be inaccessible when attempting to reach them via VPN.
All devices are unaffected and remain fully connected to Onomondo's Core Network services.
SIMs can still be managed directly in Onomondo's platform at this time.
Our team is actively working to identify the root cause and mitigate the impact. We will provide further updates as more information becomes available.