GRX Infrastructure upgrades
Scheduled for Jan 31, 12:00 - 13:00 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 16, 2023 - 17:18 CET
Scheduled
We are continuing work on upgrading our GRX core This is the second of 2 planned changes.
Posted Jan 16, 2023 - 17:11 CET
This scheduled maintenance affects: Network.