The incident has been resolved; our systems indicate that all SIMs are authenticating successfully.
Posted Apr 07, 2026 - 15:21 CEST
Monitoring
The authentication issues have now been resolved and we are seeing significant improvemnet with the devices successfully authenticating.
We will continue to monitor for an extended period and will provide further updates if more information becomes available.
In case you are still having issues, please reach out to our Support Team via our Help Center.
Posted Apr 07, 2026 - 14:43 CEST
Investigating
We are investigating an issue affecting a subset of SIMs from authenticating successfully.
This issue only affects devices attempting to authenticate, devices already connected will remain unaffected.
Our team is actively working to identify the root cause and mitigate the impact. We will provide further updates as more information becomes available.