Our incident response team has identified that network configuration changes were deployed at a GRX level without notification which has prevented devices from communicating successfully.
We are now in direct contact with the local operators who have acknowledged the issue and agreed to reverse these changes and bring these networks back online.
We will continue to provide updates as they develop.
Posted Aug 25, 2026 - 20:19 CEST
Identified
Our incident response team has identified that network configurational changes were deployed on a local level which has prevented local networks from communicating successfully.
We are in direct contact with the local operators to reverse these changes and bring these networks back online.
We will continue to provide updates as they develop.
Posted Aug 24, 2026 - 13:22 CEST
Investigating
We have detected a data service degradation on all Malawi networks since 07:36 UTC 24th of August. Currently, network attach is rejected by the local Operator Networks.
There is no further information at this time. We are actively investigating with our incident response team and connectivity partners.