Delayed authentication times on IMSI 23450

Incident Report for Onomondo

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 15:49 CEST

Monitoring

A fix has been implemented and we are now actively monitroing.

Devices should successfully authenticate as expected.

If you have any questions please reach out to our support team via support@onomondo.com
Posted Jun 02, 2026 - 13:06 CEST

Update

We have identified that this issue is also impacting authentication times on 4G as well as 2G and 3G.

This issue only affects devices attempting to authenticate with IMSI 23450 this time, devices already connected will remain unaffected.

Our team is actively working to resolve the root cause and mitigate the impact. We will provide further updates as more information becomes available.
Posted Jun 02, 2026 - 12:35 CEST

Update

We are continuing to resolve the issue and we are seeing more devices authenticating successfully.
Posted Jun 02, 2026 - 11:23 CEST

Update

We are continuing to resolve the issue and we are seeing more devices authenticating successfully.
Posted Jun 02, 2026 - 10:35 CEST

Identified

We have identified the issue and we are now seeing devices re-authenticate in a timely manner. We will continue to keep you updated as congestion continues to resolve.
Posted Jun 02, 2026 - 10:01 CEST

Update

We are continuing to investigate the issue and we will provide more information shortly.
Posted Jun 02, 2026 - 09:26 CEST

Investigating

We are investigating an issue affecting authentication times on 2G and 3G technologies.

This issue only affects devices attempting to authenticate, devices already connected will remain unaffected.

Our team is actively investigating. We will provide further updates as more information becomes available. If you have any questions please reach out to our support team: support@onomondo.com.
Posted Jun 02, 2026 - 08:51 CEST
This incident affected: Network.