Or systems indicate that all operations have returned to normal and devices should be authenticating successfully.
In case you are still having issues, please reach out to our Support Team via our Help Center.
Posted Mar 20, 2026 - 08:54 CET
Update
We are seeing that the majority of devices have recovered. We are continuing to monitor and will provide updates as they become available.
Posted Mar 20, 2026 - 08:31 CET
Monitoring
We’ve implemented changes and are now seeing a significant increase in the number of devices recovering. We are continuing to monitor to ensure full restoration.
Posted Mar 20, 2026 - 08:09 CET
Identified
Issue have been identified. Our team is working on fixing the issue.
Posted Mar 20, 2026 - 07:28 CET
Investigating
At 05:50 UTC, a subset of authentication servers (HSS/HLR) lost connectivity to the Authentication Center (AuC), causing authentication rejections. Only SIMs within the 20416 IMSI range were impacted.