Uganda data services in temporary suspension

Incident Report for Onomondo

Resolved

According to the Uganda Communications Commission, data services in Uganda have been restored and our own internal tests are also successful.
Posted Jan 28, 2026 - 12:12 CET

Monitoring

According to the Uganda Communications Commission, data services in Uganda have been temporarily suspended due to election-related procedures.

Onomondo does not have influence over this situation.

We will keep you updated as soon as new information becomes available.
Posted Jan 21, 2026 - 12:25 CET
This incident affected: Network Operators.